Overberg under maintenance

Resolved
Octotel Network Notice - OCTOTEL TELEPHONE SYSTEM OFFLINE - 9th February 2024

Started
February 09, 2024 at 7:52 AM
Status
Resolved after about 2 hours

Impact

Degraded performance
Affected
Service Regions
Southern Suburbs
West Coast
Atlantic Seaboard
Northern Suburbs
Cape Town Central
Overberg
Helderberg
Garden Route
Cape Winelands
Gauteng
  • Resolved
    Resolved

    Dear Octotel Customer,

    The incoming phone call query to Octotel Contact Centre has been resolved.

    Octotel apologises for any inconvenience caused.

    Kind Regards,

    Octotel Noc

  • Investigating
    Investigating

    Dear Octotel Customer

    We are currently experiencing technical difficulties with out telephone phone system impacting incoming calls to and from our Customer Contact Centre.

    Our team is actively investigating the issue and working diligently to resolve it as soon as possible.

    Kindly utilize our email support platform for any urgent inquiries or support requirements, in the interim. Please direct your messages to support@octotel, and our dedicated team will prioritize your requests and provide assistance promptly.

    Kind Regards,
    Octotel Noc